Apache HTTP installimise tõrkeotsingu juhend

Apache HTTP installimine on alati lõbus. Mõni päev tagasi installisin ApaOS 2.4 CentOS VM-i ja sain sellega hakkama mitu viga.


Arvasin, et oleks kasulik kokku panna viide.

APR-i ei leitud

[[e-posti aadress on kaitstud] httpd-2.4.25] # ./konfigureerimine – lubatav-ssl
valitud paigutuse kontrollimine … Apache
mkdir -p töötamise kontrollimine … jah
grepide otsimine, mis käsitlevad õngejadasid ja -e … / usr / bin / grep
egrep … / usr / bin / grep -E kontrollimine
ehitamissüsteemi tüübi kontrollimine … x86_64-unknown-linux-gnu
hostisüsteemi tüübi kontrollimine … x86_64-unknown-linux-gnu
kontrollitakse sihtsüsteemi tüüpi … x86_64-unknown-linux-gnu
seadista:
konfigureerimine: Apache Portable Runtime teegi seadistamine…
seadista:
APR-i kontrollimine … ei
konfigureerimine: tõrge: APR-i ei leitud. Palun lugege dokumentatsiooni.
[[e-posti aadress on kaitstud] httpd-2.4.25] #

APR tähistab “Apache Portable Runtime” ja seda on vaja allikast kompileerida. Kui olete minuga samas olukorras, siis järgib tahet päästmine sina.

Esiteks, peate installima APR.

  • Laadige APG-i abil alla uusim versioon

vidin https://www-eu.apache.org/dist/apr/apr-1.6.3.tar.gz .

  • Paberi allalaaditud fail

gunzip -c apr-1.6.3.tar.gz | tõrva xvf –

  • loob uue kausta “apr-1.6.3
  • Minge sisse ja kompileerige käsuga configure

./ seadistamine

See võtab mõne sekundi ja kui see on tehtud, saate kiire tagasi (veenduge, et viga pole).

  • Viimane samm oleks installimine käsu make abil

tegema
pane installima

Kui see valmis, proovisin Apache’i installida ja sain uue vea.

APR-kasutust ei leitud

[[e-posti aadress on kaitstud] httpd-2.4.25] # ./konfigureerimine –enable-ssl –enable-so
valitud paigutuse kontrollimine … Apache
mkdir -p töötamise kontrollimine … jah
grepide otsimine, mis käsitlevad õngejadasid ja -e … / usr / bin / grep
egrep … / usr / bin / grep -E kontrollimine
ehitamissüsteemi tüübi kontrollimine … x86_64-unknown-linux-gnu
hostisüsteemi tüübi kontrollimine … x86_64-unknown-linux-gnu
kontrollitakse sihtsüsteemi tüüpi … x86_64-unknown-linux-gnu
seadista:
konfigureerimine: Apache Portable Runtime teegi seadistamine…
seadista:
APR-i kontrollimine … jah
seades CC väärtusele "gcc"
seades CPP väärtuseks "gcc -E"
seades CFLAGS väärtuseks " -g-O2-niit"
seades CPPFLAGS väärtuseks " -DLINUX -D_REENTRANT -D_GNU_SOURCE"
seades LDFLAGS väärtuseks " "
seadista:
konfigureerimine: Apache Portable Runtime Utility teegi seadistamine…
seadista:
aprillikuu kontrollimine … ei
konfigureerimine: tõrge: APR-kasutust ei leitud. Palun lugege dokumentatsiooni.
[[e-posti aadress on kaitstud] httpd-2.4.25] #

Kui teil on ka viga „APR-util not found”, siis saite hakkama installige järgmine.

  • Laadige alla uusim APR-util allikas

vidin https://www-eu.apache.org/dist/apr/apr-util-1.6.1.tar.gz .

  • Paki allalaaditud gz-fail välja

gunzip -c apr-util-1.6.1.tar.gz | tõrva xvf –

  • Minge vastloodud kausta apr-util-1.6.1 ja installige järgmiste käskude abil

./ configure – with-apr = / usr / local / apr / bin / apr-1-config
tegema
pane installima

Proovisin uuesti Apache’i installida ja sain veel ühe tõrke.

pcp-config libpcre jaoks ei leitud

Seda ma sain.

kontrollida, kas C kompilaator töötab … jah
C kompilaatori vaikeväljundfaili nime kontrollimine … a.out
käivitatavate järelliidete kontrollimine…
kontrollime, kas koostame risti … ei
objektifailide järelliidete kontrollimine … o
kontrollida, kas me kasutame GNU C kompilaatorit … jah
kontrollides, kas gcc aktsepteerib -g … jah
gcc valiku otsimine ISO C89 aktsepteerimiseks … pole vaja
C eeltöötleja käivitamise kontrollimine … gcc-E
gcc valiku otsimine ISO C99 aktsepteerimiseks … -std = gnu99
pcre-configi kontrollimine … vale
konfigureeri: tõrge: libpcre’i pcre-config ei leitud. PCRE on vajalik ja saadaval aadressil http://pcre.org/

PCRE tähistab Perli ühilduvaid tavalisi avaldisi ja see viga sai lihtne lahendus. Peate lihtsalt installima pcre-devel paketi.

yum install pcre-devel

Pole veel möödas, sain järgmise OpenSSL-iga seotud katsega veel ühe.

OpenSSL-i versioon on liiga vana

kontrollitakse, kas lubada mod_slotmem_plain … ei
kontrollides, kas lubada mod_ssl … kontrollida sõltuvusi
kontrollitakse OpenSSL-i … kontrollitakse kasutaja pakutavat OpenSSL-i aluskataloogi … ./konfigureerimine: rida 25426: cd: / usr / bin / openssl: pole kataloog
/ juur/httpd-2.4.25
lisades "-I / root / httpd-2.4.25 / lisada" saidile CPPFLAGS
seades MOD_CFLAGS väärtuseks "-I / root / httpd-2.4.25 / lisada"
seades ab_CFLAGS väärtuseks "-I / root / httpd-2.4.25 / lisada"
lisades "-L / juur / httpd-2.4.25 / lib" LDFLAGS-ile
seades MOD_LDFLAGS väärtuseks "-L / juur / httpd-2.4.25 / lib"
OpenSSL versiooni kontrollimine >= 0,9,8a … Rike
konfigureerimine: HOIATUS: OpenSSL-i versioon on liiga vana
ei
kontrollitakse, kas lubada mod_ssl … configure: tõrge: mod_ssl on taotletud, kuid seda ei saa ehitada eelduslike tõrgete tõttu
[[e-posti aadress on kaitstud] httpd-2.4.25] #

Esimene asi, mida peate tagama, et teil oleks OpenSSL-i uusim versioon, mis oli minu puhul, nii et mul oli vaja see installida arenduspakett, ja sellega oli kõik korras.

yum install openssl-devel

xml / apr_xml.c: 35: 19: fataalne viga: expat.h: sellist faili või kataloogi pole

Aprillit koostades sain selle vea.

[[e-posti aadress on kaitstud] apr-util-1.6.1] # make
make [1]: kataloogi `/opt/temp/apr-util-1.6.1 ‘sisestamine
/ bin / sh / usr / local / apr / build-1 / libtool –silent –mode = kompileerige gcc -g -O2 -põime -DHAVE_CONFIG_H -DLINUX -D_REENTRANT -D_GNU_SOURCE -I / opt / temp / apr-util- 1.6.1 / sisaldab -I / opt / temp / apr-util-1.6.1 / include / private -I / usr / local / apr / include / apr-1 -o xml / apr_xml.lo -c xml / apr_xml. c && puudutage xml / apr_xml.lo
xml / apr_xml.c: 35: 19: saatuslik viga: expat.h: sellist faili või kataloogi pole
# kaasata
                   ^
koostamine lõpetati.
muuda [1]: *** [xml / apr_xml.lo] viga 1

Kui teile kuvatakse see tõrge, saate selle lahendada, installides expat-devel paketi.

yum install expat-devel

konfigureerimine: tõrge: $ PATH-st ei leitud ühtegi aktsepteeritavat C-kompilaatorit

C-kompilaatorit ei leita on tüüpiline mis tahes tarkvarakomplekti jaoks ja selle saate parandada kompilaatori installimisega.

yum install gcc

nghttp2 versioon on liiga vana

See kehtib konkreetselt siis, kui proovite Apache’i installida koos HTTP / 2-ga. Kuvatakse järgmine tõrge.

kontrollides, kas lubada mod_http2 … kontrollida sõltuvusi
kontrollitakse OpenSSL-i … (vahemällu salvestatud) jah
seades MOD_LDFLAGS väärtuseks " -lssl -lcrypto -lrt -lcrypt -lpthread"
seades MOD_CFLAGS väärtuseks " "
seades MOD_CPPFLAGS väärtuseks "-DH2_OPENSSL"
nghttp2 kontrollimine … kasutaja esitatud nghttp2 aluskataloogi kontrollimine … puudub
pkg-configi kontrollimine mööda … nghttp2 versiooni kontrollimine >= 1.2.1 … RIKKATUD
konfigureerimine: HOIATUS: nghttp2 versioon on liiga vana
ei
kontrollitakse, kas lubada mod_http2 … konfigureerimine: tõrge: mod_http2 on taotletud, kuid seda ei saa ehitada eelduslike tõrgete tõttu

Ja kui jah, saate selle parandada, installides nghttp2 nagu allpool.

  • Laadige alla uusim nghttp2 versioon siin

vidin https://github.com/nghttp2/nghttp2/releases/download/v1.37.0/nghttp2-1.37.0.tar.gz

  • Paberi allalaaditud fail

tar -xvf nghttp2-1.37.0.tar.gz

  • See loob uue kausta, minge selle sisse ja käivitage järgmine

./ seadistamine
tegema
pane installima

Kui see on vigadeta tehtud, käivitage uuesti Apache allikakood HTTP2-ga. See peaks olema korras.

Lõpuks suutsin Apache edukalt installida. Kui olete huvitatud Apache HTTP Serveri administreerimise tundmaõppimisest, siis vaadake seda veebikursus.

Jeffrey Wilson Administrator
Sorry! The Author has not filled his profile.
follow me
    Like this post? Please share to your friends:
    Adblock
    detector
    map